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In addition to this printed guide, a flash based step by step is also available. 
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Background 

  

His and Hers Postcards 
There are two sets (front and back) of base postcard background images from which PrintShop Mail will 
intelligently select based upon the gender of the customer.  This is often referred to as conditional images, which 
are built using what PrintShop Mail (PSM) calls the Expression builder.  Conditions or conditional logic are the 
business rules that the customer determines on if something appears or disappears. In this demo for example, if 
the Gender field contains “male” print the sunset and coconut images, if it says, “female,” then print the woman 
walking down the beach and the starfish.  Intelligently selecting the background is referred to as page picking in 
PrintShop Mail. 

 

PrintShop Mail enables a real time preview of your work as you design for WYSIWYG (what you see is what you 
get) results.  PrintShop Mail also has a built in warning system letting you know if you are not going to get the 
expected results, down to the detail of which record will not print correctly. 

 

PrintShop Mail optimizes the print streams in many different possible ways in order to ensure the fastest and 
more efficient printing and finishing possible.    

 

This Step by Step Guide ends with an Appendix section which outlines important things to know when working 
within PrintShop Mail including detailed set up for the printed output, as well an outline of additional sales support 
that is available 

 

Estimated Time:  20 minutes for download, 25 minutes to build the form for the first time. 
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Setting Up 

 

 
1) DOWNLOADING THE SOFTWARE: Download PrintShop Mail from the web or from a CD. From the 

web is recommended as you know you will always have the latest version. 
a) Go to www.objectiflune.com 
b) Click on Downloads, then Software Demo. (See Image Above.) 
c) Click on PrintShop Mail 
d) Fill out the short form then hit Submit. 
e) Download the Software 

 
The demo version of PrintShop Mail is fully functional. It will allow you to print 25 records at a time. Not 
pages, but records. Records meaning the number of lines in your database, or number of people for 
which the document is being created, regardless of the number of the pages in the design. 
 
2) PUTTING THE RESOURCES INTO PLACE  

a) Create a folder on your Desktop titled, “PSM Travel Postcard Demo.”  
b) Open the Zip file of resources and extract the contents to that folder. 
 

3) INSTALL THE POSTNET BARCODE FONT For this demo, you will need to download the provided 
PSM Postnet barcode font. 
a) Choose Start > Settings > Control Panel (Note: In Windows XP, choose Start > Control Panel) 
b) Double-click the Fonts folder. 
c) Choose File > Install New Font. 
d) Browse to the new folder on your desktop, locate the PSM_Postnet.ttf. 
e) Click OK to install the fonts. 

 
4) OPEN PRINTSHOP MAIL 
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5) PRINTSHOP MAIL DESIGN TOOL OVERVIEW.  Take a moment to familiarize yourself with 

parts of the interface you may not be used to seeing in other Windows based interfaces.  

a) Moving from left to right, starting with the Toolbar on the left: 
i)  Select Mode 
ii)  Edit Mode 
iii)  Zoom Level 

iv)  Eyedropper 
v)  Place PDF 
vi)  Insert Image File 

vii)  Place Variable Text 
viii)  Insert Image Box 
ix)  Rotate 

b) The Layout Design Area is where the design is done. 
c) The Properties Panel allows you to make changes to any object on the page. 
d) The Data Fields Tab shows you fields of data from the database you have attached to the job. 
e) Along the bottom of that area, are the Variables Tab (allows you to set how numbers, currencies 

and dates are displayed and printed), the Layouts Tab (allows you to navigate the various 
layouts or pages in the design and the elements on each), and the Verification Results Tab ( 
where warnings for the whole document will be listed when a Verify and Print is done.)  Please 
NOTE: In the image above, the Verification Results area is along the bottom.  See Tip below. 

f) Then the toolbar along the bottom helps with layout navigation and views: 

i)  First Layout 

ii)  Previous Layout 
iii)  Next Layout 

iv)  Last Layout 
v)  Zoom 
vi)  Show/Hide Formatting 

vii)  Toggles Preview Mode 
viii)  Show/Hide Rulers 
ix)  Toolbars 

x)  Record Navigation 

TIP: All the panels above can be moved and docked where you prefer and are most comfortable. 

 
 

Layout Design 
Area 

Properties 
Panel 

Data Fields 
Tab 

Variables 

& Layout Tabs 
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Page Setup  

 
Let’s get started! 

Note: If you see a , check out the 
coordinating screen shot on the right.  

 
6) Go to “File > Page Setup” 
7)  Click “Change” button to select the 

PostScript printer to which you want to 
print. 

8)  Change paper size to 11”x17”, also 
called Tabloid. 

9) Set “Apply to”: Whole document 
10) Click OK 

  

Insert Background Images 
 

 
11)  Go to “Insert >” 
12) Select “Image File…” 
 

Note: It is possible to import a PDF or Microsoft Word 
document, which will automatically be converted to a 
PDF file from the Insert > PDF dialog box. 

Background images can also be in image formats: .eps, 
.gif, .ico, .jpg, .tif, and .bmp. 

 
 

 
13)  Browse for image (cardfront-male.jpg) 
14) Click “Open” 

Tips: If you are inserting a PDF as a background image, 
you can either go to the Insert menu, choose PDF, or 
you can also click the “Place PDF” button in the Tools 
toolbar. Importing a PDF in this way allows you to not 
only proportionally scale, but also place the PDF 
anywhere on the layout.  This will create layouts that 
match the pages in the PDF file. 
Also, if there are multiple images on a page, PrintShop 
Mail supports drag and drop onto the screen. 

 

 

 

 

Step 7

Step 8
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Set Layout Size 
 

A PrintShop Mail document may consist of one 
or more layouts, which can be of different 
sizes. PrintShop Mail supports multiple layout 
sizes within one document.  
 
On startup, PrintShop Mail always starts out 
with a blank layout. The size of this blank 
layout is set to Fit to Page. The layout size and 
shape (tall or wide) can be specified per each 
layout by selecting Size in the Layout menu or 
by selecting the layout in Layouts Panel. 
 
 
15) Go to “Layout > Size” 
16)  Change “Size:” to “Fit to Objects” 
17) Set “Apply to”: Whole document 
18) Click OK 

 

Add a Bleed Margin 

 

A bleed margin is a part of your layout that is 
printed to the edge of a finished page.  Once a 
page is reproduced on press, the bleed margin 
is removed. 
 
In PrintShop Mail, your total layout size (as 
seen in Size in the Layout menu) includes the 
bleed margin 
 
 
19) Go to “Edit > Preferences” 
20)  Select the “Imposition” icon on the left 
21)  Change “Bleed Margin” to Include in 

Job 
22) Change Width to 0.125” 
23) Click OK 

 
NOTE: If the layout includes a bleed margin, crop marks 
will, by default, be included.  Crop marks are printed lines 
that make it easier to trim the document to its finished 
size after the bleed margin is removed.  You can change 
the size of the marks in this same dialog box. 
 

 

Step 20

Step 21 
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Set Print Job Settings 
 

First we will set the print margins.  Specifying 
the offset that causes the output to shift, 
relative to the top left corner of the page. In the 
layout view, the printable area lines take the 
print offset into account. If you specify a 
positive X-offset, the printable area shifts to 
the left. 
 
24) Go to “Edit > Preferences” 
25)  Select the Print Job icon on the left 
26)  Change X-offset and Y-offset to 0.125” 

 
Note: If your measurements are not in inches, you can 
change that by clicking on the Program icon on the left of 
the dialog box and change the Measurement In settings 
to inches, then click Apply. 
 
 
27) Click Apply 
 
 
Note: We are going to use the default Technology for 
optimizing the print stream, Optimized PostScript.  See 
the Appendix for a full list of supported technologies: 
 

  

  
Next we will set the multi-up or n-up settings 
for this job. 
 
 
28)  Select the Repetition icon on the left 
29)  Set the Horizontal and Vertical 

repetitions to 2. The number in 
parentheses indicates the maximum 
number of repetitions possible with the 
current layout and print settings.      

30) Click OK 

 

Note: More information on Repetition Settings can be 
found in the Appendix. 

 

 

 

 

Step 25

Step 26

Step 28

Step 29
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Set Up the Back of the 
Postcard 

 

31)  Go to Layout > Insert 
32) Insert 1 layout at end of document 
33) Click OK 

 
 
34) Go to Insert > Image File… 
35)  Browse for the cardback-male.jpg file 
36) Click Open. 
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Adding a Unique Code 
Number Using the Counter 
Expression 

 

 

 

 

 
The postcards have a unique Sweepstakes 
code, which can be generated from the 
Counter functionality in the Expression Builder. 
 
PrintShop Mail allows you to create 
customized serial numbers without a 
database. You can use these numbers to 
serialize such items as raffle tickets, coupons 
or self-mailers. In combination with the 
barcode functions, you can create serially 
numbered barcodes. 
 
37)  Click on Place Variable Text button 
38)   Move your cursor to the right of and 

drag a box to the right of Your Code on the 
bottom left of Layout 2. 

39) Type @personalcode@  Anything between 
the at (@) signs, is considered to be a 
variable. You are creating variable data 
that is not in the database. 

40)  Highlight the text and apply the light 
turquoise color, the font size to 16 and 
make it Bold, then click outside of the box. 

41)  Right click on what appears to be an 
empty box and choose Edit Expression > 
Variable “personalcode” 

 

Step 37 

Step 38

Step 40

Step 41 
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42)  Double click on Counter from the 
Functions menu and a Wizard opens. 
a) In the start value, enter 789654321 

(these are all random numbers, but you 
can make them anything you want.) 

b) In the End value, type 999999999 
c) Set the step size to 10. Default is 1. 
d) Set the number of positions to 9.  This 

refers to number of characters the 
counter will create. By default no extra 
characters will be added. 

e) For leading zeros, True is for leading 
zeroes, False for no leading zeroes 
(default), type True 

f) Click OK, twice. 
 
 
 

 

Database 
 

Now let’s add the data.  
 
43) Go to Database > Open 
44)  Browse for Travel.xls file 
45) Click Open 
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Map and Format Variable Text  

 

 

46) Map the variable data for the address 
block, on the right side of Layout 2.   
a)  Drag and drop fields from Data 

Fields window onto layout the First 
name field.  

b) Click and drag the lower left corner of 
the text box so that it is wide enough to 
accommodate the address block and 
bar code.  The text will default to the 
turquoise color from the previous text 
box. Click inside the text box, then 
highlight the text, change it to black at 
11 point size. 

c) Position cursor to the end of the First 
name variable, type a space, then drag 
up the Last name field and hit enter to 
add a new line.  

d) On the second line, drag the Address 
field. Hit enter. 

e) On the third, drag City, type a comma 
then a space, then the State field, type 
two spaces followed by the Zip. Hit 
enter. 

f) On the last line drag the Barcode field.  
Highlight it, then select the 
PSMPostNetTt font from the font 
dropdown menu to apply the correct 
barcode font. 

g) Click outside of the box to see a 
preview and drag it into place. 

 

 
Tip: In other jobs, if you have an text box that needs to 
appear on multiple layout pages: 

1) With the textbox selected, go to Edit > Copy 
2) Then go to Edit > Paste To > Remainder of Document 

You will have to make the changes on the other layouts to 
make sure the text box is in the right location. You can 
browse layouts from the Layouts panel. 
 

  

 

47) Add the first name to the front of the 
postcard. 
a)  Click on the Layouts Tab and choose 

Layout 1. 
b) From the Data Fields tab, drag the First 

name field onto the screen on Layout 1. 
c)  Highlight the text and set it to Times 

New Roman, 22 points, italicized and 
plum colored. 

d)  Click outside of the box and drag it 
into place. 

 

 

Step 46 a. 
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Making the Images Variable 
 

We’ve set up the front and back of the postcard, 
but we want the guys to get the picture with the 
palm tree on the front and the coconut on the 
back, and the ladies to get the image of the 
woman walking down the beach on the front and 
the starfish on the back.   
 
48)  Go to first layout using layout arrows on 

the lower left, or from the Layout tab. 
49)  Right click the image and select Edit 

Expression… from the context menu 

 
 
50) The Expression will say: "cardfront-male.jpg" 

The images purposefully are named to match 
the field in the database called Gender.  This 
makes it easy to set up the Expression (also 
known as condition).   
a) Edit the expression, by first highlighting 

and deleting “male.jpg”. 
b) Click outside of the quotation marks, and 

click on the ampersand (&), then 
c)  Double click on the Gender field. 
d) Click ampersand again, then 
e) Click on the Quotes button and type 

<.pdf> so that it looks like this:  
“cardfront-“ & [Gender] & “.jpg” 
 

51) Click OK. Viola! The image will now change 
based upon the data. 
 

52) We need to set up the back to be conditional 
as well. 
a) Follow Steps 48 – 50, but with the 

following exceptions: 
i) Layout 2 instead of 1 
ii) It should look like:  

“cardback-“ & [Gender] & “.jpg” 
 

 
 

 

Step 48
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Printing 
53) Now it’s time to print your variable data job. 

a) Click on File > Print to get the Print 
Dialog Box. 

b)  Select your PostScript printer from 
the drop down menu to which you are 
printing. 

c) If you are printing in demo mode (you 
do not need to have a dongle), you will 
be able to send 25 records at a time.  
After that, you will need to close and 
re-start PrintShop Mail, to be able to 
print 25 again. 

d)  In the Record Range section, 
choose from 1 to 25. 

e)  Click on Properties and from the 
printer driver, set up for duplex printing. 

f)  Then click Verify and Print.  See the 
callout box below on Verifying a 
PrintShop Mail Document. 

g)  Click Print. 

Congratulations! You have completed building your variable data postcard. 

About document verification 
 Before printing your document, you can verify that it is ready to print at two levels:   

 Layout level: Warnings at layout level will show the layout number in the Warnings Panel. 
 Record level: Warnings at record level will show the layout number and record number in the Warnings 

Panel. 
PrintShop Mail performs the following checks:  

 Are any images or PDF files missing? 
 Are all items placed within the printable area? 
 Does a text object contain more text than the text box can hold? For example, the following warning is 

displayed: "Text does not fit in its bounding box". You can prevent this warning from appearing again by resizing the 
text box or by linking the text box to another text box.  
 
Warnings.  While you are working, PrintShop Mail will dynamically check for any possible errors on the layout and will 
display any occurring error in the Warnings Panel. 
 
Verify Document   When you select from the Layout menu, Verify Document, a progress bar will be displayed, 
showing the amount of records being checked. The warnings for the whole document will be listed in the Verification 
Results Panel.  Note: Verify document will be stopped when 1000 warnings are found or when you press the cancel 
button on the progress bar. 
  
Here is a list of a few possible messages: 

 Object is placed beyond the printable area 
 Object is not entirely placed on the layout 
 Text file not found 
 Variable X  is not linked to an expression 
 Text does not fit in its bounding box 
 Image X not found 
 Error loading image 
 Page number X is invalid; this PDF only contains Y pages 
 Variable X: argument Y is invalid 
 Variable X: barcode input string Y is invalid 
 Variable X: date format Y is invalid 
 X contains at least one TrueType font that is not embedded in the PDF 
 Variable X: database field Y not found 

Step 53b 

Step 53d 

Step 53e

Step 53f 

Step 53g
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Appendix: PrintShop Mail Preferences 
 

The Preferences dialog box of PrintShop Mail contains a lot of power.  To get to Preferences, 
Click on Edit across the top, then Preferences. 

 

In PROGRAM SETTINGS are two sections: 
 
GENERAL OPTIONS 
Variable Markers.   Specify the characters that delimit 
(enclose) the variables in your text objects. 
  
Measurement in.   Select the unit of measurement for 
PrintShop Mail. 
  
Items without database.   Specify the total number of 
records when no database is open. 
  
Interface language  (Windows Only).   Specify which 
language you want to use. 
  
Interface theme.  Specify the appearance of the application 
user interface. It is possible to choose from: Classic, Blue, 
Aqua. 

LAYOUT APPEARANCE 
Select the color for specific lines:  
Bleed, Folding, Crop marks (Mac OS) 
 
Printable area.  Specify the order in which the printable areas are drawn, relative to the objects. Top specifies that the 
areas are always visible, Bottom that they are obscured by objects. 
  
Guide lines.   
 Specify the order in which the guide lines are drawn, relative to the objects. Top specifies that the lines are always 
visible, Bottom that they are obscured by objects. 
  
Magnetic strength.  Define guide line sensitivity when moving or resizing objects. When the cursor comes within the 
specified pixel range on either side of a guide line the object snaps to it. 
 

 

PRINTJOB SETTINGS: 
 
PRINT MARGINS 
Specify the offset that causes the output to shift, relative to the 
top left corner of the page. In the layout view, the printable area 
lines take the print offset into account. If you specify a positive X-
offset, the printable area shifts to the left. 
 
TECHNOLOGY 
Select which print technology is used to optimize your PostScript 
output: Standard PostScript. Optimized PostScript.  AHT, Creo 
VPS, Fiery FreeForm, Fiery FreeForm 2, PPML, PPML/VDX, 
VIPP. 
 
TROUBLSHOOTING 
Print report page. Specify that a report page is printed at the end 
of the job. 
 
Send custom error handler. Specifies whether a Postscript error 
will generate a custom error page containing tips on how to solve 
the problem. Leave this box unchecked if you want your printer to 
handle any errors. 
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Appendix: PrintShop Mail Preferences (continued) 
 

 

REPETITION SETTINGS 
 
LAYOUT REPETITION 
Layout Repetition.  Specify how the actual multi-up is done. The 
number between brackets indicates the maximum number of 
repetitions possible with the current layout and print settings.      
  
Spacing between layouts.  Specify the horizontal and vertical 
distance between each layout 
  
Priorities.  Specify how the database order is printed. You can 
specify:  Left to right, Top to bottom and Front to back. 
 
For example: To print Through-the-stack, set top priority (1) to Front 
to back, priority (2) to Top to bottom and priority (3) to Left to right. 
This way the first record is printed on the top left corner of the first 
page, the second record is printed on the top left corner of the 
second page, etc. This eliminates the need for collating after the job 
is printed. 
 

Mirroring.  Specify that the positions of the layouts on the back of each page should match de positions of the layouts 
on the front of each page. In effect, the layout positions on the back will be mirrored horizontally. You can specify: 
Simplex, Based on driver settings, Flip on long edge.  Note: Some printer drivers do not correctly report duplex 
settings. You can force PrintShop Mail to mirror the layout positions on the back by specifying "Flip on long edge". 
 
 

 

IMPOSITIONING SETTINGS 
 
BLEED MARGIN 
Specify bleed margin information: None, Add to Job, Include in Job, 
and Width. 
  
CROP MARKS 
Select: None, Standard or Japanese.  Note: You can only specify 
crop marks if you have specified a bleed margin.  
 
Double Sided: When you select this option the crop marks will be 
printed in both sides of the paper.  
 
Gap size: Specify gap size as the distance between the actual crop 
mark and the edge of the layout. 
 
Color (Windows): It is possible to select a color for the Crop marks. 
  
FOLDING LINES 
Specify the length of folding lines. 

 

 
PUBLISH TO WEB SETTINGS 
 
For integrating with PrintShop Web, it allows you to publish 
documents created in PrintShop Mail to the Web.  You can set the 
Server address (URL) and specify Login information to that server.  

 

PSMTDSBSKJ012908 


